4.0.0.12

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.13

4.0.0.11

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.12

4.0.0.10

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.11

4.0.0.9

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.10

4.0.0.8

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.9

4.0.0.7

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.8

4.0.0.6

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.7

4.0.0.5

  • Correct the display of OPEN, CLOSE and CONTINUE messages in SAS. (VOLTE-9763)

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.6

4.0.0.4

  • Update the AnnouncementProfile and PlayAnnouncement feature to support the NumberOfRepetitions parameter (STLIN-123)

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.4

4.0.0.3

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.3

4.0.0.1

  • This release is built on and requires JDK 11. It requires Rhino 3.0 or later releases.

  • Renamed address lists CallBarring:BlackList to CallBarring:BlockList and CallBarring:WhiteList to CallBarring:AllowList. (STLIN-122)

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.1

3.1.0.4

Dependency Updates

  • Update the Sentinel Common dependency to 3.1.0.4

3.1.0.3

Dependency Updates

  • Update the Sentinel Common dependency to 3.1.0.3

3.1.0.2

  • Update SS7FsmObjectCodec to support Encodable Object types (STLIN-121)

Dependency Updates

  • Update the Sentinel Common dependency to 3.1.0.2

3.1.0.1

Dependency Updates

  • Update the Sentinel Common dependency to 3.1.0.1

3.1.0.0

  • First release in the 3.1.0.x series.

  • Rename SBB feature artifacts from -du.jar to .du.jar. (VOLTE-8239)

Dependency updates

  • Update the Sentinel Common dependency to 3.1.0.0

3.0.0.2

Dependency updates

  • Update the Rhino dependency to 2.6.2.7

  • Update the SIS dependency to the 2.6.2.9

3.0.0.1

Dependency updates

  • Update the Rhino dependency to 2.6.2.3

3.0.0.0

  • First release of the 3.0.0.x series

Dependency updates

  • Update the SIS dependency to the 2.6.2.4

  • Update the Sentinel Common dependency to 3.0.0.0

2.9.0.2

Dependency updates

  • Update the Rhino dependency to 2.6.2.2

  • Update the Diameter RA dependency to 3.1.2.1

  • Update the HTTP RA dependency to 2.5.0.1

  • Update the Sentinel Common dependency to 2.9.0.2

2.9.0.1

Dependency updates

  • Update the Rhino dependency to the 2.6.2.1

  • Update the SIS dependency to the 2.6.2.2

  • Update the Sentinel Common dependency to 2.9.0.1

2.9.0.0

  • First release of the 2.9.0.x series

_Dependency updates

  • Update the Rhino dependency to the 2.6.2.x series

  • Update the Rhino Element Manager dependency to the 2.6.2.x series

  • Update the SIS dependency to the 2.6.2.x series

  • Update the Sentinel Common dependency to 2.9.0.0

2.8.0.3

Dependency updates

  • Update the Rhino dependency to 2.6.1.3

  • Update the SIS dependency to 2.6.1.6

  • Update the Diameter dependency to 3.1.1.2

  • Update the Sentinel Common dependency to 2.8.0.3

2.8.0.2

Dependency updates

  • Update the SIS dependency to 2.6.1.5

  • Update the Sentinel Common dependency to 2.8.0.2

2.8.0.1

Dependency updates

  • Update the Rhino dependency to 2.6.1.2

  • Update the SIS dependency to 2.6.1.4

  • Update the Diameter dependency to 3.1.1.1

  • Update the Sentinel Common dependency to 2.8.0.1

2.8.0.0

  • First release of the 2.8.0.x series

Dependency updates

  • Update the Rhino dependency to 2.6.1.1

  • Update the Rhino Element Manager dependency to 2.6.1.1

  • Update the CGIN dependency to 2.0.0.0

  • Update the SIS dependency to 2.6.1.2

  • Update the Sentinel Common dependency to 2.8.0.0

2.7.1.3

Dependency updates

  • Update the Sentinel Common dependency to 2.7.1.3

2.7.1.2

  • First release of the 2.7.1.x series

New Capabilities

  • Added Metaswitch Service Assurance Server (SAS) support for SS7 Events (OpenRequest, InitialDP, Connect, Release, Cancel, Close)

Dependency updates

  • Update the Sentinel Common dependency to 2.7.1.2

2.7.0.8

Dependency updates

  • Update the Sentinel Common dependency to 2.7.0.8

2.7.0.7

Dependency updates

  • Update the Sentinel Common dependency to 2.7.0.7

2.7.0.5

Dependency updates

  • Update the Sentinel Common dependency to 2.7.0.5

2.7.0.4

Dependency updates

  • Update the Sentinel Common dependency to 2.7.0.4

2.7.0.3

Dependency updates

  • Update the Sentinel Common dependency to 2.7.0.3

2.7.0.2

Dependency updates

  • Update SIS dependency to 2.5.4.7

  • Update CGIN dependency to 1.5.4.4

  • Update the Sentinel Common dependency to 2.7.0.2

2.7.0.1

Dependency updates

  • Update the Sentinel Common dependency to 2.7.0.1

  • Update the Diameter dependency to 3.1.0.1

2.7.0.0

  • First release of the 2.7.0.x series

  • Update the Sentinel Common dependency to 2.7.0.x

  • Update the Diameter dependency to 3.1.0.x

2.6.0.8

  • Fix a bug when generating Correlation Data for Terminating IDPs without Location Information. (VOLTE-4207)

  • Update the Sentinel Common dependency to 2.6.0.8

2.6.0.7

  • Update the Sentinel Common dependency to 2.6.0.7

2.6.0.6

  • Update SIS dependency to 2.5.4.3

  • Update Rhino dependency to 2.5.0.2

  • Update Sentinel Common dependency to 2.6.0.6

2.6.0.4

  • New Version - no functional changes

2.6.0.2

  • Update SIS dependency to 2.5.4.2

  • Update CGIN dependency to 1.5.4.2

  • Update the Sentinel Common dependency to 2.6.0.3

2.6.0.1

  • Updated REM dependency to 1.5.0.3

  • Update Sentinel Common dependency to 2.6.0.1

2.6.0.0

  • Initial release of the 2.6.0.x series

  • Update CGIN dependency to 1.5.4.1

  • Update REM dependency to 2.5.0.1

  • Update SIS dependency to 2.5.4.1

  • Update Sentinel Common dependency to 2.6.0.x

2.5.0.0

  • Initial release of the 2.5.0.x series

  • Update Sentinel Common dependency to 2.5.0.x

2.4.0.3

  • Update CGIN dependency to 1.5.2.19

  • Update SIS dependency to 2.5.2.23

  • Add module packs for several modules (STLPACK-134, STLPACK-150)

2.3.1.14

  • Update Sentinel Common dependency to 2.3.1.16

  • Update SIS dependency to 2.5.2.21

  • Update HTTP RA dependency from 2.2.0.6 to 2.2.0.11

2.3.1.12

  • Update Sentinel Common dependency to 2.3.1.13

  • Update Diameter dependency to 2.6.0.15

  • Update SIS dependency to 2.5.2.20

  • Fix a bug in the SS7 Determine Network Operator module pack

  • Convert Sentinel SS7 mappers to publish SBB part artifacts rather than DUs

2.3.1.5

  • Update Sentinel Common dependency to 2.3.1.5

2.3.1.4

  • Update SIS dependency to 2.5.2.14

  • Miscellaneous fixes such that Sentinel SS7 passes all integration tests on top of the SIS (in addition to CGIN RA) (STLIN-52)

  • Increment OpenRefuse counter at all points where refuseDialog called/OpenRefuse sent (STLIN-73)

  • Change relay dialog to determine provider from the relayed dialog not a static provider (STLIN-53)

  • Change oAnswer to interrupt rather than notify and continue (STLIN-54)

  • Updated to FSMTool version 1.1.0.10

  • Ensure dialog resumed before refusing or relaying dialog (STLIN-40)

2.3.1.0

  • Initial release of Sentinel SS7 2.3.1 series

Previous page