4.0.0.5

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.7

4.0.0.4

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.6

4.0.0.3

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.4

4.0.0.2

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.3

4.0.0.0

  • This release is built on and requires JDK 11. It requires Rhino 3.0 or later releases.

New features

  • Add sentinel-gaa.trusted-source-ips NAF filter configuration option to explicitly trust traffic from particular client addresses. (OPT-1685)

Dependency Updates

  • Update the Sentinel Common dependency to 4.0.0.0

3.1.0.4

Dependency Updates

  • Update the Sentinel Common dependency to 3.1.0.4

3.1.0.3

  • Upate BSF to allow case insensitivity when converting IMPI to BSF address. (STLGAA-284)

  • Update Digest authentication filter to re-authenticate with new challenge if client IP address changed while using the same nonce value. (VOLTE-9061)

Dependency Updates

  • Update the Sentinel Common dependency to 3.1.0.3

3.1.0.2

Dependency Updates

  • Update the Sentinel Common dependency to 3.1.0.2

3.1.0.1

Dependency Updates

  • Update the Sentinel Common dependency to 3.1.0.1

3.1.0.0

  • First release in the 3.1.0.x series.

Dependency updates

  • Update the Sentinel Common dependency to 3.1.0.0

3.0.0.2

Dependency updates

  • Update the Rhino dependency to 2.6.2.7

  • Update the Rhino Element Manager dependency to 2.6.2.1

3.0.0.1

Dependency updates

  • Update the Rhino dependency to 2.6.2.3

3.0.0.0

  • First release in the 3.0.0.x series.

Dependency updates

  • Update the Sentinel Common dependency to 3.0.0.0

  • Update the Sentinel VoLTE dependency to 3.0.0.0

2.9.0.2

Dependency updates

  • Update the Sentinel Common dependency to 2.9.0.2

  • Update the Sentinel VoLTE dependency to 2.9.0.3

  • Update the Rhino dependency to the 2.6.2.2

2.9.0.1

Dependency updates

  • Update the Sentinel Common dependency to 2.9.0.1

  • Update the Sentinel VoLTE dependency to 2.9.0.2

  • Update the Rhino dependency to the 2.6.2.1

2.9.0.0

  • First release in the 2.9.0.x series.

Dependency updates

  • Update the Sentinel Common dependency to 2.9.0.0

  • Update the Sentinel VoLTE dependency to 2.9.0.0

  • Update the Rhino dependency to the 2.6.2.x series

  • Update the REM dependency to the 2.6.2.x series

  • Update the Diameter dependency to the 3.1.2.x series

2.8.0.3

  • Add support for new CDIV non-provisionable list, XCAP normalization and the MMTel Authorized flag in standalone installations. For existing installations, please follow the updated step 9 in the BSF installation guide. (VOLTE-6325)

  • Encode Ks_NAF as base64 in GBA_Digest calculations. (STLGAA-259)

  • Optionally hard-code TLS cipher suite name. (BUG-1339)

  • Update Datastax Cassandra driver to 3.4.0. (STLGAA-276)

Dependency updates

  • Update the REM dependency to 2.6.1.2

  • Update the Rhino dependency to 2.6.1.3

  • Update the Diameter dependency to 3.1.1.2

  • Update the Sentinel Common dependency to 2.8.0.3

  • Update the Sentinel VoLTE dependency to 2.8.0.3

2.8.0.2

  • Update the Sentinel Common dependency to 2.8.0.2

  • Update the Sentinel VoLTE dependency to 2.8.0.2

2.8.0.1

  • Update the Sentinel Common dependency to 2.8.0.1

  • Update the Sentinel VoLTE dependency to 2.8.0.1

  • Update the Rhino dependency to 2.6.1.2

  • Update the Diameter dependency to 3.1.1.1

2.8.0.0

  • First release in the 2.8.0.x series.

New features

  • Added support for GBA_Digest authentication (3GPP TS 33.220 Annex M).

  • Added Authentication Proxy servlet.

  • Added support for tracing to Metaswitch Service Assurance Server.

Improvements

  • Include query string when checking URI in NAF filter. (STLGAA-250)

  • Fix decoding of naf-key tool’s nonce argument. (STLGAA-265)

Dependency updates

  • Update the Sentinel Common dependency to 2.8.0.0

  • Update the Sentinel VoLTE dependency to 2.8.0.0

  • Update the Rhino dependency to 2.6.1.1

  • Update the REM dependency to 2.6.1.1

  • Update the Diameter dependency to 3.1.1.0

2.7.0.6

  • Fixed encoding of the XRES parameter used in AKA digest calculations. (STLGAA-247)

2.7.0.5

Dependency updates

  • Migrate to Sentinel VoLTE 2.7.0.5

2.7.0.3

Dependency updates

  • Migrate to Sentinel VoLTE 2.7.0.3

2.7.0.2

Dependency updates

  • Migrate to Sentinel VoLTE 2.7.0.2

2.7.0.1

Dependency updates

  • Migrate to Sentinel VoLTE 2.7.0.1

  • Update the REM dependency to 1.5.0.5

  • Update Diameter dependency to Diameter RA 3.1.0.1

2.7.0.0

Dependency updates

  • Migrate to Sentinel VoLTE 2.7.0.x

  • Update the REM dependency to 1.5.0.4

  • Update Diameter dependency to Diameter RA 3.1.0

2.6.0.1

Provisioning module changes

  • The Sentinel GAA provisioning module has been migrated to the new Rhino Element Manager plugin framework (new in REM 1.5.0). It is now packaged as a REM plugin jar instead of an extension zip. See Installing the NAF Filter.

Dependency updates

  • Migrate to Sentinel VoLTE 2.6.0.x

  • Migrate to Rhino 2.5.0.x and REM 1.5.0.x

  • Update the Cassandra CQL dependency to 1.1.0.0

  • Update the REM dependency to 1.5.0.3

  • Update the Sentinel VoLTE dependency to 2.6.0.1

1.1.0.1

  • Update Diameter dependency to Diameter RA 2.7.0.5 (STLGAA-235)

1.1.0.0

  • Migrate to Sentinel VoLTE 2.5.0 and Diameter 2.7 (STLGAA-230).

  • Use LOCAL_QUORUM consistency level for all Cassandra reads and writes (STLGAA-218).

1.0.0.7

  • Fix calculation of AKA digest values in BSF (STLGAA-214).

  • Fix a BSF Cassandra operation that was not updating statistics (STLGAA-213).

  • Log exceptions in setSbbContext() using SLEE tracers, not stderr (STLGAA-205).

1.0.0.6

  • Product renamed as Sentinel Authentication Gateway.

  • Fixed handling of Ub resynchronization requests in BSF (STLGAA-206).

  • NAF filter retries bootstrapping if B-TID not known or expired (STLGAA-210).

  • BSF was storing TMPIs incorrectly in database (STLGAA-208).

  • BSF rejects challenge responses that have the incorrect realm (STLGAA-209).

  • BSF rejects challenge responses that use unsupported algorithms (STLGAA-212).

  • Fix superfluous alarm raised by Cassandra-CQL RA when applying default configuration (STLGAA-203).

  • Simplify and document Diameter Zh properties in deployment module’s config.properties (STLGAA-202).

1.0.0.5

  • Improved performance of GUSS XML marshalling and unmarshalling (STLGAA-198).

1.0.0.4

  • First release of Sentinel Authentication Gateway